文章

【GESP】C++一级练习BCQM3086,判断数正负

GESP一级知识点if分支语句练习,逻辑简单。

BCQM3086

题目要求

描述

给定一个整数N,判断其正负。如果N>0,输出positive;如果N=0,输出zero;如果N<0,输出negative。

输入

一个整数N(−109≤N≤109)。

输出

如果N>0, 输出positive;
如果N=0, 输出zero;
如果N<0, 输出negative。

输入样例

1

输出样例

positive


题目分析

  • 读入1个值,本题明确为整数
  • 直接用if语句判断即可,按照对应的条件进行输出。

代码参考

1
2
3
4
5
6
7
8
9
10
11
12
13
14
#include <iostream>
using namespace std;
int main() {
    int k;
    cin >> k;
    if (k > 0) {
        cout << "positive";
    } else if (k == 0) {
        cout << "zero";
    } else {
        cout << "negative";
    }
    return 0;
}

所有代码已上传至Github:https://github.com/lihongzheshuai/yummy-code

本文由作者按照 CC BY 4.0 进行授权