文章

【GESP】C++一级练习BCQM3149,重复说话

GESP一级知识点for循环语句和输出语句,非常简单。

BCQM3149

题目要求

描述

有一天小明说脏话时被老师听到了,结果被罚在黑板上写 n 遍”I don’t say swear words!”。

输入

输入只有一行,其中含有一个正整数n(1≤n≤10),代表被罚写的次数。

输出

输出 n 行”I don’t say swear words!”。

输入样例

2

输出样例

I don’t say swear words!
I don’t say swear words!


题目分析

  • 读入一个整型变量
  • 直接用for循环,每个循环用输出语句输出即可。

原本是一道非常简单的题目,孩子随手编写的代码如下:

1
2
3
4
5
6
7
8
9
10
#include <iostream>
using namespace std;
int main() {
    int n;
    cin >> n;
    for (int i = 1; i <= n; i++) {
        cout << "I don't say swear words!" << endl;
    }
    return 0;
}

知识拓展

C++一级知识点研究,cout和printf差异分析,从理论上分析一下现象和可能的原因。


所有代码已上传至Github:https://github.com/lihongzheshuai/yummy-code

本文由作者按照 CC BY 4.0 进行授权